support home

Back to website
Welcome
Login  Sign up

Discussion regarding the iubenda cookie law solution for WordPress

Sono titolare di due siti web entrambi su wordpress, per provare il servizio di iubenda ho acquistato una licenza, l'ho configurata scegliendo tutti i servizi del mio sito ( http://www.pappa-reale.net ) poi ho installato il plugin iubenda cookie nella sua ultima versione dichiarata stabile e compatibile con la versione aggiornata di wordpress, ma nel momento in cui attivo il plugin per inserire il codice generato per la mia licenza i contenuti del sito scompaiono, ad eccezione dell'header e del footer, per aggirare il problema ho inserito il codice come widget di testo nel footer e così ho la visualizzazione della mia privacy policy si nel versione breve che in quella estesa. Tuttavia non ho nessun banner che si apre per avvertire l'utente, da parte mia credo di non avere cookie di profilazione, ma solo il plugin di google analytics che ho anonimizzato, mi chiedo se l'assenza del banner sia dovuta al fatto che non sono riuscita ad installare il plugin o se non avendo cookie di profilazione sia giusto così. Prima di procedere con la seconda licenza volevo essere sicura di aver fatto tutto correttamente, ho provato più volte a contattare il supporto di iubenda sia tramite mail che tramite chat, ma non ho avuto nessuna risposta, neanche per confermare se per l'acquisto di due licenze una è gratis, come indicato sul sito. I miei siti hanno wordpress aggiornato all'ultima versione e utilizzano entrambi il tema Stockholm, confidando in una risposta, vir irngrazio, Antonella
  • Ciao, ho aggiornato il plugin, ora però il menù del tema è scomparso e il footer delle pagine risulta corrotto: http://pasteboard.co/13F4HTdw.png Nel footer c'è il link alla privacy generata da iubenda, che dev'essere ciò che genera gli errori che si vedono. Se elimino il link la pagina non viene visualizzata del tutto (bianca). Disattivando il plugin di iubenda il sito torna a funzionare correttamente. Sembrerebbe comunque qualcosa ancora legato a Yoast SEO, perché disattivando quest'ultimo con il plugin di iubenda attivo il sito viene visualizzato correttamente (anche se banner e blocco non funzionano comunque).
  • Ciao Giovanni, riesci a scriverci su info@iubenda.com? In questo modo riusciamo a mandarti privatamente delle versioni del plugin da poter testare. Grazie mille!
  • Certamente, vi scrivo lì. Grazie.
  • Buon giorno, tempo fa vi ho scritto, via email, per un problema relativo al caricamento incompleto di alcuni stili CSS (inline, credo). Mi rispose Fabio ... ma senza fix. Oggi, al verificarsi nuovamente della questione, ho provato a ricontattarlo ma senza esito. Pertanto, vi giro QUI il ticket: A parte che il website è molto più lento di quando, al contrario, disabilito iubenda, soprattutto nel caricare il box immagine (quello in alto a sinistra) Ma veniamo al problema di cui sopra. I TITOLI delle sezioni che compaiono sopra i posts grid, devono comparire correttamente al centro e non allineati a sinistra e, inoltre, il pulsantone quasi a fondo pagina, "VADO ALLO SPECIALE" dovrebbe comparire su sfondo blu Instagram e testo bianco. Sembra che in qualche modo il plugin blocchi gli stili inline. Di certo, la cosa che non comprendo appieno è data dal fatto che, questo problema si verifica SOLO se, a navigare è un utente guest. Appena mi accredito come user o amministratore, il website viene caricato regolarmente e normalmente. Ovviamente, tutto questo, se disabilito il plugin viene visualizzato correttamente. Qualcuno ha idea di come risolvere il problema? http://dverxo.it
  • @g.partengo, esaminiamo il problema e cerchiamo di riprodurlo. Ti facciamo sapere se abbiamo bisogno di ulteriori info. Nel frattempo: riusciresti a provare a disattivare tutti i plugin diversi dal nostro e vedere se uno di essi confligge con esso? Facci sapere :)
  • Buon giorno, grazie per la cortese risposta; tuttavia le prove con i plugin le avevo già effettuate disabilitando tutto tranne Visual Composer necessario al tema in uso. Ciò detto, tengo a precisare che utilizzo SuperCache di SiteGround e che ho provato iubenda sia con la voce "Lascia intatti gli script della pagina se l'utente ha già dato il consenso (migliora le prestazioni, altamente consigliato, da disattivare solo qualora tuo sito utilizzi un sistema di cache)" disabilitata che abilitata. Il risultato è sempre lo stesso. Ho notato, però un rallentamento nel page loading, quando vengono attivati i plugin AddThis e Easy Social Share Button di Codecanyon. Se disabilito iubenda, pulisco cache server e browser, il website viene caricato velocemente e senza problemi.
  • Buongiorno, vi scrivo per chiedervi supporto. Ho l'impressione che sulla Home del mio sito Wordpress (ultima versione) non appaia il banner dei cookie Iubenda implementato con l'apposito plugin ma che esso appaia correttamente nelle pagine degli articoli. Il plugin è aggiornato alla release di ieri 1 ottobre. Sospetto si tratti di un qualche conflitto con qualche plugin Wordpress (Uso W3 Total Cache e Yoast SEO) dato che ci sono stati degli aggiornamenti negli ultimi giorni. Non è un problema di template del sito in quanto ho fatto una prova cambiandolo, riscontrando lo stesso problema. Vi risulta qualche problematica in merito che possa essere fixata con nuove release?
  • @Ilario, puoi confermare che stai usando la versione 1.10.4?
  • Salve, sì leggo che è la versione 1.10.4. Ho riscontrato questa problematica solo negli ultimi giorni in seguito ad aggiornamenti automatici del sito Wordpress che hanno coinvolto la versione e alcuni plugin. Se può servire, Yoast Seo è la versione 2.3.5. e W3 Total Cache è la 0.9.4.1
  • A noi il banner non è apparso e abbiamo dovuto disattivare il plugin in quanto ci creava problemi con la condivisione degli articoli su Facebook. Potete verificare anche voi? Grazie
  • Ciao a tutti, riuscite a provare la versione disponibile a questo link? http://andrea.s3.iubenda.com/jMe9gYxn7q Fateci sapere! :)
  • Con la versione disponibile che avete linkato riscontro ancora problemi se attivo il plugin Yoast SEO: nel mio caso non appare neanche la home page. Con il plugin Yoast SEO disattivato, invece, il sito funziona e il banner appare. :)
  • Buona sera, scaricato il nuovo plugin e installato ... pare funzionare!!! Mi riservo di effettuare ancora alcuni test, nel frattempo GRAZIE!
  • Come non detto, il problema persiste. Dunque, analizzando la cosa, se vi può esser utile ... disabilitando il plugin tutto funziona mentre con iubenda attivo lo stile passato inline ad un elemento in particolare non compare fino a quando non effettuo il login come admin al website. il CSS in questione è il seguente: element.style { color: #3d464d; font-family: Roboto Condensed; font-size: 21px; font-weight: 400; text-align: center; } Questo stile non è generato tramite codice manuale ma attraverso impostazioni ad hoc usando Visual Composer. .....
  • Oggi ho aggiornato il plugin all'ultima versione e ho riscontraro un problema nella mia homepage: non viene più caricata la slider, alcuni widger ecc.. E' la terza volta che aggiornando il plugin succede qualcosa al mio sito, potete verificare bene il plugin prima di lanciare aggiornamenti? Ho fatto investigare a programmatori esperti di Site Ground, gentilissimi e alla fine questa è la loro risposta: I have carefully investigated the problem, and tried to resolve it however to no avail. As a part of my investigation I updated the ownership and permissions of the files and folders as in most cases such issues can be cause by that. Also I disabled the plugin iubenda-cookie-law-solution to see it it causes the issue and then cleared the application's cache: Code: domimaga@domimagazine.it [~/public_html]# wp plugin deactivate iubenda-cookie-law-solution Success: Plugin 'iubenda-cookie-law-solution' deactivated. domimaga@domimagazine.it [~/public_html]# wp cache flush Success: The cache was flushed. Then I tired to cahnge the theme of the application but to no avail. The process could not be straced as well. We do have experienced engineers/technicians, seasoned in dealing with various hosting-related WordPress issues. We do try to assist as much as possible with any application based related issue that you might approach us with, although sometimes there are more complex issues that require deeper investigation, which includes dedicating time and effort for debugging a problem, and this is usually best done by a professional developer. You have a WordPress multi-site application that is quite customized and uses numerous plugins. Thus creating backups before any changes to the plugins or upgrades is essential. The best case scenario in your case is to restore the site from a backup. Note that it is also possible to revert the site to a working state from an older date. We have daily backups kept for the last 30 days. non mi resta che fare un restore. Seconda volta in meno di una settimana e due volte problema con plugin iubenda. Grazie
Login or Signup to post a comment