support home

Back to website
Welcome
Login  Sign up

Joomla Plugin 1.2.5 and PHP 7.3

Hi, on my Joomla site I have a warning since I've upgraded to PHP 7.3:

1) Warning: preg_match(): Compilation failed: invalid range in character class at offset 4 in path_to_my_site_folder/plugins/system/iubenda/iubenda-cookie-class/simple_html_dom.php on line 1375. (several lines)

2) preg_match_all(): Compilation failed: invalid range in character class at offset 4 in path_to_my_site_folder/plugins/system/iubenda/iubenda-cookie-class/simple_html_dom.php on line 686

3) Invalid argument supplied for foreach() in path_to_my_site_folder/plugins/system/iubenda/iubenda-cookie-class/simple_html_dom.php on line 693

I'm testing it in xampp but I've tried even activating Error Reporting on production Linux server for a few seconds and it has the same problem.

Would you help me, please? Does Joomla plugin need to be updated?

Thank you
Kind regards
Login or Signup to post a comment